Boost Wi-Fi calling no longer working

Still gliding along with Boost Infinite (post-RW), for now at least. Noticed “WiFi Calling” is no longer working. I keep getting a “Try again later” whenever I try to turn it back on. It worked great with RW & even after the changeover kept right on working with Boost Infinite. Was great to have during the last time there were area wide cell phone problems. Now no longer works & when I tried talking to Boost’s customer service I was told since I didn’t buy my phone direct from Boost (bought it direct from RW) they couldn’t help.
Anyone else experiencing similar issues? Any ideas what to check out &/or a work-a-round?

DISH decides to retire the RW brand, designates Boost Infinite as the successor brand then after migrating subscribers to the designated successor brand refuses to support phones purchased from RW. That’s just swell. It’s stories like this that make me not regret no longer doing business with any DISH brands.

In fairness to the agent(s) with whom you communicated, it’s likely they are unaware of the history involved. In other words, the fault lies with DISH corporate.

The above said, most commonly, this scenario results from lack of a valid E911 address.

Questions for you:

  1. What is the brand, model and (if applicable) generation of the involved phone?
  2. Have there been any recent changes to the phone, in particular Android updates?
  3. What is the current version of Android on the phone?
  4. Do you know whether the SIM in the phone is for AT&T’s or T-Mobile’s network? If not, dial *#06# and report the first 5 digits of the ICCID.
  5. Was the previously working WiFi calling toggled off intentionally? Or; did it seemingly disable itself?

Hey @nobull,

In addition to the 5 questions I asked in my initial reply, please try the following:

  1. Dial *#*#4636#*#* on your phone
  2. Tap Phone information
  3. Is the toggle for WiFi Calling Provisioned on or off? If off, is it possible to toggle it on there?

The above works on Google Pixels and Motorola phones but does not work with Samsung’s bundled Phone app. It can be made to work on Samsung phones by installing Google’s Phone app then temporarily making Google’s Phone app the default in place of Samsung’s bundled Phone app.

rolandh, Thanks for the interest. Sorry for somewhat slow reply but am a 24 hr caregiver (family member is doing ok) & time is at a premium. I’ll reply to your Q’s below but a quick review … Wi-Fi calling has been working fine (On most of time) until 4-6 (?) wks ago. E911 was loaded as appropriate. Can’t check now until I can turn WiFi calling back on. Also a year or so ago had cracked the screen & replaced damaged unit under MotoCare warranty. Once replacement in house reloaded phone & everything worked like normal including WiFi calling. Currently WiFi & data seems to be behaving as normal on this phone. Answering your Q …
Q1: Motorola Moto g stylus 5G, model# XT2131-1 (Hardware version “pvt”)
Q2 & Q3: Android version 12, no recent changes. The only major thing I can think of that changed on the phone is I finally, I believe, I managed to get the phone unlocked. (WiFi calling stopped working before I rec’d unlock code from Boost so don’t think it’s causing this issue). I’ve been pursuing unlock since before the changeover from RW as time permits (starts & stops, a lot of resistance/lack of help @ Boost).
Q4: I’ve been told both so here is 1st 5 of ICCID 89014
Q5: Occasionally Wi-fi calling shut off on it’s own but I believe it happened after I put phone into airline mode while in ICU. Done it before & when I come out of airline could alway turn it back on
WiFi calling Provisioned Q: Yes it shows toggled on but toggle is light grey color & verbage is faded (assume it’s informational only) "mobile Radio Power shows active toggle(green color). Noticed that my "NR state is “NOT_RESTRICTED” so I assume it means phone is actually unlocked??

Hope I’ve included all you asked for. Any reply I will get to as time permits but it could be a bit of time. Thanks again

Good Morning @nobull,

Understood and no problem. Happy to hear your family member is doing OK.

If WiFi calling was working on the replacement phone also, that’s not the problem.

I don’t remember RW having sold the 5G variant of the Moto G Stylus but my memory is probably failing me.

Carrier unlocking the phone shouldn’t have impacted WiFi calling and since it stopped working prior to the carrier unlock, that’s not it either.

89014 is AT&T, 89012 is T-Mobile, 89105 is the fabled “Rainbow” (DISH native) SIM. As an aside, the only former RW members who might have a “Rainbow” SIM would be if they purchased a new phone directly from Boost post migration that is compatible with DISH’s native network.

Airplane mode shuts down both the phone’s WiFi (unless WiFi is manually reenabled while in Airplane mode) and cellular radios.

It’s more than informational. The toggle being in the on position even though greyed out suggests the phone is indeed provisioned for WiFi calling.

But; when you look in Settings, the toggle is off before attempting to enable WiFi calling, correct?

NR (short for New Radio) is another way of saying 5G just as LTE is another way of saying 4G. It’s not indicative of a phone’s locked/unlocked status but “NOT_RESTRICTED” means your phone is working for 5G.

So; enough with attempted diagnosis. Your initial description of the phone’s behavior when attempting to enable WiFi calling suggests it is having a problem connecting with AT&T’s VoWiFi (WiFi calling) backend. The “Try again later” message suggests the phone is trying (and failing) to establish a connection to AT&T’s VoWIFi backend (possibly because it can’t verify the 911 address previously supplied).

Is the phone connected to WiFi when attempting to enable WiFi calling? If so, have you tried to enable WiFi calling with WiFi temporarily turned off? If not, give that a try. Ignore any message about needing an active WiFi connection for WiFi calling to work. Obviously, an active WiFi connection is required to use WiFi calling but an active connection is not required to enable/disable WiFi calling.

If still no go, the usual next step is a Network Settings Reset. On a Moto running Android 12 the path would be:

  1. Open Settings
  2. Tap System
  3. Tap Reset Options
  4. Tap Reset WiFi, mobile & Bluetooth

The downside is you may lose saved WiFi network passwords and Bluetooth pairings. You would need to do those again. In particular, you would want to have the password for your home WiFi network available.

It’s more than informational. The toggle being in the on position even though greyed out suggests the phone is indeed provisioned for WiFi calling.

But; when you look in Settings, the toggle is off before attempting to enable WiFi calling, correct?
Yes toggle is OFF

YES, phone connected to WiFi. So tried to connect with WiFi temp off. Saw message and went past to same results. Then tried going thru message (to turn WiFi on following prompt on phone) … thought it was going to work (took same amount of time that it does to normally turn “on”) but ultimately failed to same “try again Later message”. Finally reset WiFi, even though hate losing previous sets, but want WiFi calling to work. After reset finished & reconnected to home WiFi network tried to turn WiFi calling on … thought it was going to work but ultimately failed to same “try again Later message”. Tried again to just turn WiFi calling on but now back to the same quick “try again Later message”.

Same problem here. I have Boost Infinite. I just checked my iPhone 13 mini, which I bought from RW, and its Wi-Fi calling no longer works. Everything is set up properly, and it worked the last time I tried it. I’m not too bothered by this because Wi-Fi calling has always been so flakey that I just use my landline.

Funny thing: I also have Google Voice, and Wi-Fi calling has always worked just fine with it.

Are you getting the same error message as @nobull?

No. I get “Calling home” when I try to call my landline. After a while I get “Call failed.” . When I try to call in, the call goes directly to voice mail.