Restart needed for calls or texts to be sent/received

When my old phone died in Nov 2022, I had to change from RW My Choice to RW 5.0 and so I purchased a phone from RW.
The ATT signal was generally weak (2 bars), and I noticed that a number of times, I couldn’t send/receive texts or calls and I had to restart the phone.
It’s as if the signal gets lost and then the phone doesn’t pick up the signal again, even if 1-2 bars are showing!
I didn’t know if this was an ATT issue, a weak signal issue, or a phone issue.
It actually got a bit worse this month, too, which is part of why I finally switched carriers.

With the recent RW changes, I switched to US Mobile, WARP (Verizon).
The signal fluctuates between 1-3 bars at my home, but I’ve been able to send/receive texts and calls.
But today, twice, I wasn’t getting texts (I’d get the “tap to retry” notification for an MMS message). I restarted the phone and everything worked. It happened twice, and both times, I restarted and it worked.

I googled this, and apparently people do have this issue, with various carriers, but a lot of the info is years old.

I’m just curious if others on this forum have had this experience, and what they attribute it to?

It’s not the end of the world, but it is an inconvenience. I never had this on RW My Choice!!


I’ve recently switched to Tello for my primary number and occasionally texts won’t send until I toggle airplane mode on/off. On Verizon I’ve noticed occasionally that when I’m in an area of no coverage my phone won’t connect when returning to coverage until an airplane mode toggle.

I will try that next time, rather than a restart!
I also tried turning Mobile Data off then on, but it didn’t do whatever a restart did!

I remember @billg documenting this long ago, I think he had realized it was a regular experience on T-Mobile’s network.


That’s helpful to know – that it happens with different networks and with other people.
I was thinking it might be my (new as of November) phone!!

1 Like

So, the issue of having “bars” but no service continued. I’d switch on/off Airplane Mode or even a restart. The phone appears to have bars, but I couldn’t send/receive texts or calls.

I had this same issue with RW 5.0, with no resolution.

So I contacted US Mobile service and described the issue. I got the following instructions which I followed, and the issue has not occurred again (it’s day 4 now). I also asked if I had to re-input APN settings and they said no, not at this point – just monitor how it’s working. The phone has been fine all this week! Yay!

Here was USM’s response:

It seems like your phone is having difficulty connecting to the network despite showing a signal. One solution you can try is resetting your network settings. This will erase all saved Wi-Fi networks and passwords, Bluetooth connections, and cellular settings on your phone. Here’s how to do it:

Go to Settings > System > Reset options.

Touch “Reset Wi-Fi, mobile & Bluetooth” > “Reset settings.”

Touch “Reset settings.”

Please power off your phone for 60 seconds and then power it back on before testing the services for at least 24 hours. We also suggest testing the services in different locations to determine if the issue is with your current location or with the network.

If the problem persists, we can send you a new SIM card to help resolve the issue. Please provide us with your shipping address.

Please don’t hesitate to reach out if you require further assistance. We’re available 24/7 to help.

1 Like

So I followed the instructions from US Mobile customer service on Mon 8/21.
Everything has worked fine since – it’s been 10 days!!

1 Like