WiFi Calling problem?

There appears to be a problem with my WiFi Calling. It was working until relatively recently. Now, if I’m on WiFi, my calls drop after a couple of seconds. If I turn off WiFi, calls are fine. If I use an alternate app to make calls over the internet (eg Whatsapp), that’s fine. If I use WiFi in airplane mode, it says it cannot make a call as there is no WiFi.
Restarting the phone didn’t help. I’ve now turned off WiFi calling altogether.
I was planning to poke around the RW community to see if others were having the same issue, before googling further. (Sniff sniff sad face.)

Republic MyChoice, Pixel 4xl, Android 13

Don’t know if you updated your APNs (Access Point Names) before the RW Community collapsed but @rolandh published a great doc that included both T-Mobile and AT&T settings but I think this is what was included for MyChoice (T-Mobile):

T-Mobile data & APN settings

By default, Airplane mode turns off both the phone’s cellular and WiFi radios, however, WiFi can be manually reenabled. If you leave the phone in Airplane mode but manually reenable WiFi; are you able to make calls without them dropping? If not, what, if anything, do you receive for an error message?

I had the same issue with my Samsung S21+ 5G and gave up on Wi-Fi calling in favor of my strong AT&T signal. I even activated my my A32 5g with a a 5.0 SIM and had the same problem with it. I know it’s not my Wi-Fi because my SO’s Samsung S8 on Mint works perfectly over the Wi-Fi at my home.

Some time back Dish support was working with me on the A32 5G and needed to speak with me on a different phone. I worked with them for an hour and half without a hiccup on her S8. That tells me there is something fishy with Wi-Fi calling specific to Dish/AT&T.

Hi Roland! Yes this was airplane mode with WiFi reenabled, plus I double-checked that the WiFi/internet was working. When I try to make a call it says, “Turn off airplane mode or connect to a wireless network to make a call.”

With regard to the APN settings, is that saying everything should be identical to the link jBen sent, or just the numbers? Eg for MMSC instead of http://wholesale.mmsmvno.com/mms/wapenc it should be http://mms.msg.eng.t-mobile.com/mms/wapenc ?

Good Morning @joannamv

Apologies for the delayed reply. I wanted to take some time and test a household Pixel with an RW My Choice SIM. I was able to keep a test call over WiFi up for over a half hour, so it wouldn’t appear your experience is typical.

If not already done, remove the old Republic app from your Pixel. It is no longer useful and can cause problems. Do not reinstall the old Republic app.

APN settings are not usually the culprit behind WiFi calling anomalies, so i’m going to ask that you not concern yourself about changing those for now. I am going to ask that you turn Airplane mode off then verify the following settings on your Pixel:

  1. Open Settings
  2. Under Internet, verify you are connected to your WiFi network
  3. Tap SIMs
  4. Tap Republic
  5. Verify Wi-Fi calling is toggled on
  6. Tap Wi-Fi calling
  7. Tap Calling preference
  8. Verify Call over Wi-Fi is selected then dismiss the dialog by tapping anywhere on the screen
  9. Tap the back arrow to the upper left
  10. Tap Access Point Names
  11. Verify you see a single Republic\/wholesale APN and that it is selected. If you’ve made any edits to that APN, please let us know.
  12. Tap the back arrow to the upper left three times
  13. You should be back at the Network & internet page
  14. At the bottom of that page, tap Adaptive connectivity then toggle it off
  15. Exit Settings
  16. Power down your phone

Next, power cycling your network equipment (even though everything else appears to be working) can’t hurt. If uncertain about how to power cycle your networking equipment, please advise us of who your Internet provider is and whether you are using a separate modem and router or whether there is a single gateway device.

Once power cycling the networking equipment is complete, power your phone back on and test to see if WiFi calling is behaving better.

"I was hopeful that turning off Adaptive Connectivity might be the magic fix, but nope.

I’ve since just given up on it, I don’t need the capability most of the time. Didn’t bother resetting my networking equipment because that wouldn’t help me at the cafe or the grocery store or the other grocery store, etc.

If anybody else has a similar problem in the future I will try to troubleshoot some more.