No calls - happened suddenly

We are at out wits end. My phone is going directly to voice mail, I’ve tried everything, and I often don’t get any voice mail messages. I’ve checked DND, call forwarding, reset networks…,nothing works. When checking cellular settings, it spins and then says network or sim problem, but then it reads the settings. I thought it was my phone but my husband has the same problem. After 4 hours of looking at everything, both our phones worked, then suddenly they didn’t again. When mine worked it showed all call forwarding as disable, yet I was able to get voice mail after not answering my phone (it rang). So was my husband, but his was not disabled. Then my call forwarding to voicemail reset itself and we both lost calling again. When I clicked on network carrier, 3 T-Mobile options came up that I could actually choose…my husbands phone only said republic. Now mine only says republic too, but without a choice to toggle it as he has. This is crazy, we have basically lost the use of our phones except for texting.

You don’t state which phone, but it looks like you are on the MyChoice plan (T-Mobile is the carrier)
I would go through this excellent article by @rolandh to ensure your APN’s are set properly: Are You Having Cellular Connectivity Issues?

  • If still no luck, then you might try the folks that Support Republic Wireless


Hi @Doro and welcome to the RW Users Community! We are a group of present and past RW Users. This Community, however, is in no way directly affiliated with the brand now calling itself RW by DISH.

Beginning in March 2022, RW by DISH removed its proprietary WiFi-first technology from remaining legacy My Choice service lines. With that, the quality of one’s cellular coverage became considerably more important. I mention this because calls going straight to voicemail without ringing one’s phone is classic behavior when cellular coverage is weak. To help us best help you, we need additional information:

  1. If comfortable doing so, please share the zip code (nothing more) where you are having this experience?
  2. What is the brand, model and (if applicable) generation of your phone?
  3. Please sign into your Republic account here:
  4. For the line of service associated with your phone number, please confirm you see My Choice Talk & Text?
  5. Please also confirm whether or not there is cell data attached to your plan and how much is left?


I see you mention your husband having some difficulties as well. For the sake of keeping this conversation focused on your issues, it would be best to separate your husband’s issues. I would ask that he open his own topic and answer the questions I posed to you.

Thanks jBen and Roland’s…I did finally reset the APN….and one of the TMobile options showed up toggled and I was able to receive calls but could not call out. Then my phone stopped receiving calls and said it was not in service. I restarted the phone and the APN switched to republic, and calls went to voice mail. Back to refresh APN and T-Mobile showed up again and the phone worked…for a while, until it reset to republic again. My cell signal is strong. My zip is 29063 and yes I have a My Choice plan with 1 gigabyte of data. , I have used 59MB this month since the 9th. I have a Moto E4.I am a senior and we use our phones very little but sure would like them to be more reliable than what has happened lately. I tried to uninstall,the Republic app, but it only uninstalls the updates, the app remains.

Hi @Doro,

I wonder if, instead of trying many things when this happens, you might try simply toggling airplane mode on, then back off, and give the phone time to reconnect to the cellular network to see if that helps?

Since it’s happening to two phones quite suddenly, I would think it is possible it is more like a network problem, not something specific to the phone, and making lots of changes on the phone could get you into a worse state. (My head spins, reading all the things you’ve done!)

Is your husband’s phone also a Moto E4? Are all the apps up to date on both phones?

No matter your age, it’s quite reasonable to want your phone to work when you need it.

Thanks Southpaw, we did all that over the course of hours, trying one thing at a time with simpler trials first. We did try shutting off airplane mode, disconnecting wifi all together, call forwarding, etc. I thought it was my SIM card until my husband checked his and it was doing the same. The only consistant thing we’ve found is the APN settings, and it works on both phones, his is an E4 plus. We just can’t keep the settings on what comes up when you refresh, it keeps defaulting to “republic” after a period of time. We can both receive and call out on the refreshed settings, but we can’t call each other’s phones. I agree, the variables were getting ridiculous, we’d fix one and another would pop,up. Still trying to figure out how to delete the old republic app although I’m getting info from Dish on it, so I’m not sure that is a smart move.

I would refer you to the following (from Republic Wireless), IF your device allows the removal, else you will need to remove all updates and then disable it.

We’ve got them working, so far. I’m just having trouble trusting it’s reliability. When I refreshed my APN and t mobile LTE was chosen as the default, we could only get calls with wifi disabled. I chose t mobile IMS and now we are able to get calls with wifi on. I just am not sure if republic will default me back to republic APN … so far, so good, I’m just posting this in case it helps anyone else still on the My Choice plan.

Hi @Doro,

We’re very happy to hear things seem to be sorted for you. I’m operating from memory but when using an RW 4.0 (My Choice) SIM with a Moto E4, I believe one should see the following APNs:

  • T-Mobile IMS
  • T-Mobile US 260 LTE
  • T-Mobile US DUN
  • T-Mobile US 260 MMS

Of those, the logically correct selection would be T-Mobile US 260 LTE but I’m certainly not here to argue with your success in selecting T-Mobile IMS instead.

You should be able to use WiFi for Internet data, however, absent RW’s proprietary technology (no longer available), your phone(s) will not be supported for WiFi calling or text messaging over WiFi. For those, you are entirely reliant on the cellular network.

Republic isn’t doing anything on the network side that would cause a change to your phone’s APNs. The thing that might be doing so is the Republic app if somehow it remains operational at some level. I understand you have uninstalled app updates but have you disabled the app entirely? You might want to verify as follows:

  1. Open Settings
  2. Tap Apps
  3. Tap Republic Wireless
  4. Tap Disable
  5. Tap Disable App

Thank you rolandh. Disabling the republic app allowed calls to go through on the LTE with wifi on. Thank you, because every time we’d power off our phones it would reset to the republic APN! It hasn’t happened since I disabled the app. Crossing my fingers!

jBen….if I had remembered how to disable the app, you probably would have fixed my problem with your step one. Thank you…I had so many variables, I missed looking up that one. I appreciate your help.